Sunday, May 22, 2011

Latest Yahoo! Mail Beta has a problem with BlackBerry mail setup

Yesterday I was cleaning up unwanted data from my BlackBerry handheld, and I also removed some of my mail boxes as I am not using some of them very actively. There were 9 mail accounts configured which were even confusing me also sometimes. I decided to go with 3 as of maximum mail accounts to use in phone.

While doing this, I removed my Yahoo mail id also from BlackBerry, which is actually my first even mail account I opened over 10 years back. I thought to keep it in my phone just for the sake of having it for such a long time. I tried adding it, and it was giving me 'invalid email address or password' error. What the heck? I have been using it with same password without problems and now its no longer working? I immediately checked on my computer and same password was working correctly.

I tried same after rebooting my phone, but no luck. Checked on some blogs/forums, somewhere it was discussed to resend service books, but I am using personal mail plan with BIS, so its not applicable to me. I tried 'Register Now' from Options/Host Routing Table, but that too didn't solve my problem. Finally, I changed my Yahoo mail password, this time it took little longer to give same silly authentication error. No other option is left at this time which any user can think of to make it work.

I was about to call BlackBerry support for this, then I recalled the change I made in my yahoo mail since I configured it in my BlackBerry, and that was choosing this new Yahoo! mail beta version. Ooo la la, I thought to gave it shot before reaching out to BB support, I sat back on my laptop and started finding out a way to rollback my Yahoo beta choice, it took me a little while and then I went back by 2 versions and reset to the Classic version. I was back in year 2005 or so at that time by looking at classic version of yahoo mail box. This time I tried configuring it in the phone, AND IT WORKED. Isn't it funny? After configuring it successfully on the phone, I switched my yahoo mail again to latest beta, and things working seamlessly on phone also now.

New Yahoo! beta version certainly have some problem with BlackBerry adapters, they should look into it as soon as possible. I'll also try to post this problem to them, let's see if they'll fix this before more users get frustrated in same situation.